Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA と言われた時の解決法

NO IMAGE

ちょっとはまったので備忘録てきに残しておく。

最近Lets encryptを思考停止しながらsudo apt install letsencryptしたら Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA っていう感じでエラーが出てきた。

どうやらUbuntuのレポジトリに入っているものは若干古いバージョンの模様。ちなみにこのエラーは1/9にTLS-SNI-01による申請(?)が禁止されたことによる模様。

目次

解決法

単純に最新版のcertbotを落としてくるだけ。

というわけでcertbotのホームページに行ったら便利なやつがあったのでそれを使う。

ApacheをUbuntu 16.04-LTCで動かしている人はこれで大丈夫なはず。

$ sudo apt-get update //レポジトリのアップデート
$ sudo apt-get install software-properties-common
$ sudo add-apt-repository ppa:certbot/certbot //専用レポジトリの追加
$ sudo apt-get update //レポジトリのアップデート
$ sudo apt-get install python-certbot-apache //インストール 

んであとは

sudo certbot --apache

してあとはでてくる指示にしたがって選択とかしていけば勝手に証明書がインストールされてた。
だいぶ進化しててちょっと驚き

未分類カテゴリの最新記事